<!DOCTYPE html> <!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]--> <!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]--> <!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]--> <!--[if gt IE 8]><!--><html lang="en-US" class="no-js"><!--<![endif]--><head>  <script src="/cdn-cgi/apps/head/oH5C0ZGLIS0Ec_UtBMdOH3gw91k.js"></script><script type="text/javascript" src="/wp-content/themes/sohh/js/segmenter.min.js"></script>   <script async src="https://www.googletagmanager.com/gtag/js?id=UA-198055-1"></script> <script>window.dataLayer = window.dataLayer || [];
  	function gtag(){dataLayer.push(arguments);}
  	gtag('js', new Date());
    gtag('set', {'dimension3': sjc.expSeg});
  	gtag('config', 'UA-198055-1');</script> <meta charset="utf-8">  <!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]--> <meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="pingback" href="https://www.sohh.com/xmlrpc.php">  <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><script>(function(h,c){h[c]=h[c]+(h[c]&&' ')+'quform-js'})(document.documentElement,'className');</script><meta property="og:title" content="Gucci Mane&#039;s Wife Keyshia Ka&#039;oir Shows Off Growing Baby Bump In High Heels: &quot;Mrs Davis&quot;" /><meta property="og:description" content="Vixen Keyshia Ka&#039;oir is making sure everyone is keeping tabs on her baby bump. The hip-hop model went online this past weekend to share new looks at her growing" /><meta property="og:image" content="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19.jpg" /><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Gucci Mane&#039;s Wife Keyshia Ka&#039;oir Shows Off Growing Baby Bump In High Heels: &quot;Mrs Davis&quot;" /><meta name="twitter:description" content="Vixen Keyshia Ka&#039;oir is making sure everyone is keeping tabs on her baby bump. The hip-hop model went online this past weekend to share new looks at her growing" /><meta name="twitter:image" content="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19.jpg" /><meta name="author" content="Angie Dare" /><title>Keyshia Ka&#039;oir&#039;s Growing Tummy Has Her Glowing In High Heels &ndash;</title><meta name="description" content="Vixen Keyshia Ka&#039;oir is making sure everyone is keeping tabs on her baby bump. The hip-hop model went online this past weekend to share new looks at her" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/" /><meta property="article:publisher" content="https://www.facebook.com/sohhdotcom" /><meta property="article:published_time" content="2020-08-24T11:10:34+00:00" /><meta property="article:modified_time" content="2020-08-24T15:49:05+00:00" /><meta property="og:image" content="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19.jpg" /><meta property="og:image:width" content="1600" /><meta property="og:image:height" content="1200" /><meta property="fb:app_id" content="138633649642" /><meta name="twitter:creator" content="@sohh" /><meta name="twitter:site" content="@sohh" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.sohh.com/#website","url":"https://www.sohh.com/","name":"","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.sohh.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/#primaryimage","inLanguage":"en-US","url":"https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19.jpg","width":1600,"height":1200,"caption":"@sohh @sohhdotcom"},{"@type":"WebPage","@id":"https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/#webpage","url":"https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/","name":"Keyshia Ka'oir's Growing Tummy Has Her Glowing In High Heels &ndash;","isPartOf":{"@id":"https://www.sohh.com/#website"},"primaryImageOfPage":{"@id":"https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/#primaryimage"},"datePublished":"2020-08-24T11:10:34+00:00","dateModified":"2020-08-24T15:49:05+00:00","author":{"@id":"https://www.sohh.com/#/schema/person/19711013bd716b85a611f13a5d94dec6"},"description":"Vixen Keyshia Ka'oir is making sure everyone is keeping tabs on her baby bump. The hip-hop model went online this past weekend to share new looks at her","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/"]}]},{"@type":"Person","@id":"https://www.sohh.com/#/schema/person/19711013bd716b85a611f13a5d94dec6","name":"Angie Dare","image":{"@type":"ImageObject","@id":"https://www.sohh.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/babed44b6e640950f44473bb78b03103?s=96&r=g","caption":"Angie Dare"}}]}</script> <script>/**
  * based on domready (c) Dustin Diaz 2014 - License MIT
  * https://github.com/ded/domready
  */
advanced_ads_ready = ( function() {
  var fns = [], listener
    , doc = typeof document === 'object' && document
    , hack = doc && doc.documentElement.doScroll
    , domContentLoaded = 'DOMContentLoaded'
    , loaded = doc && (hack ? /^loaded|^c/ : /^loaded|^i|^c/).test(doc.readyState)

  if (!loaded && doc){
    listener = function () {
	  doc.removeEventListener(domContentLoaded, listener)
	  window.removeEventListener( "load", listener );
	  loaded = 1
	  while (listener = fns.shift()) listener()
	}
	  
	doc.addEventListener(domContentLoaded, listener )
	window.addEventListener( 'load', listener );
  }

  return function (fn) {
    loaded ? setTimeout(fn, 0) : fns.push(fn)
  }
} )();</script> <style type="text/css" media="all">@font-face{font-family:'Droid Sans';font-display:block;font-style:normal;font-weight:400;src:local('Droid Sans Regular'),local('DroidSans-Regular'),url(https://fonts.gstatic.com/s/droidsans/v12/SlGVmQWMvZQIdix7AFxXkHNSaw.woff) format('woff')}@font-face{font-family:'Droid Sans';font-display:block;font-style:normal;font-weight:700;src:local('Droid Sans Bold'),local('DroidSans-Bold'),url(https://fonts.gstatic.com/s/droidsans/v12/SlGWmQWMvZQIdix7AFxXmMh3eDs1YQ.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-display:block;font-style:normal;font-weight:400;src:local('Roboto Condensed'),local('RobotoCondensed-Regular'),url(https://fonts.gstatic.com/s/robotocondensed/v18/ieVl2ZhZI2eCN5jzbjEETS9weq8-19K7Cw.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-display:block;font-style:normal;font-weight:700;src:local('Roboto Condensed Bold'),local('RobotoCondensed-Bold'),url(https://fonts.gstatic.com/s/robotocondensed/v18/ieVi2ZhZI2eCN5jzbjEETS9weq8-32meGCQYaQ.woff) format('woff')}</style><!--[if lt IE 10]><link rel='stylesheet' id='cb-ie-only-css'  href='https://www.sohh.com/wp-content/themes/15zine/library/css/ie.css' type='text/css' media='all' /> <![endif]--><link rel='stylesheet' id='fvm-header-0-css' href='https://www.sohh.com/wp-content/uploads/cache/fvm/1597860923/out/header-17f395d3d761c74024831eb46faca93ec00fd0aa.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var param = {"vuukle_version":"2.69","api_key":"1"};
var advanced_ads_data = {"blog_id":"1"};
/*  */</script> <script type='text/javascript' src='https://www.sohh.com/wp-content/uploads/cache/fvm/1597860923/out/header-249109cca7040bdef254a800c5b5fd9c43df18f1.min.js'></script><script type='application/json' id="wpp-json">{"sampling_active":1,"sampling_rate":100,"ajax_url":"https:\/\/www.sohh.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":286774,"token":"2959d9ae4f","lang":0,"debug":1}</script> <script type='text/javascript' src='https://www.sohh.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js'></script><script type='text/javascript'>/*  */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.sohh.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"1","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/*  */</script> <script type='text/javascript' src='https://www.sohh.com/wp-content/uploads/cache/fvm/1597860923/out/header-d83f6e36028ed974ab47f3b8ba00eb6134ae2790.min.js'></script><link rel='https://api.w.org/' href='https://www.sohh.com/wp-json/' /><link rel="alternate" type="application/json+oembed" href="https://www.sohh.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sohh.com%2Fgucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.sohh.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sohh.com%2Fgucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis%2F&#038;format=xml" /><link rel="dns-prefetch" href="https://cdn.vuukle.com/"><link rel="dns-prefetch" href="https://api.vuukle.com/"> <script type="text/javascript">var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};</script> <style type="text/css">article h2, article h3 { text-transform: uppercase; } .spoiler { background-color: #f00; color: #fff; display: block; text-align:center; text-transform:uppercase; width:100%; } #evergreen-pagination { display: block; text-align: center; width: 100%; } #evergreen-pagination a { background-color: #99cc00; color: #ffffff; } .cb-module-block .format-video .cb-mask a:after, .cb-module-block .format-audio .cb-mask a:after, .cb-module-block .format-gallery .cb-mask a:after { background: rgba(153,204,0,.5); border: 1px solid #000; border-radius: 0% 0%; top: 85%; left: 90%; } .sc-gZMcBi inUaCH { display: none; } .cb-credit-line { background: rgba(255,0,0,.8); } #bc-area { border: 3px solid #f00; margin-bottom:10px; padding: 5px; text-align: center; } .featured-menu-tab { background-color: #000; font-size: 16px; } .featured-menu-tab a { color: #fff !important; } .featured-menu-pop { background-color: #2323F1; font-size: 16px; } @media only screen and (max-width: 420px) { #tyche_corner_video_container{ bottom: 60px !important; } } @media only screen and (min-width: 421px) { #tyche_corner_video_container{ bottom: 100px !important; } } .honest-abe { border:1px solid #000; } .wp-block-pullquote, .wp-block-media-text { border: 2px dashed #99cc00; padding: 0; } .wp-block-pullquote strong, .wp-block-media-text strong { color: #009900; } .wp-block-pullquote p, .wp-block-media-text p { font-size: 18px; padding: 8px; margin: 0; text-align: left; } .wp-block-pullquote cite { display: none; margin: 0; } figure blockquote { margin: 0; } #tyche_trendi_video_container { bottom: 125px !important; } .wp-block-pullquote a, .wp-block-media-text a { border-bottom: 2px solid #090; } #cb-nav-bar .cb-mega-menu-columns .cb-sub-menu > li > a { color: #f2c231; } .cb-entry-content a {color:#009900; }.cb-review-box .cb-bar .cb-overlay span { background: #a3d5ff; }.cb-review-box i { color: #a3d5ff; }.cb-review-box .cb-bar .cb-overlay span { background: #222; }.cb-review-box i { color: #222; }.cb-meta-style-1 .cb-article-meta { background: rgba(0, 0, 0, 0.2); }.cb-module-block .cb-meta-style-2 img, .cb-module-block .cb-meta-style-4 img, .cb-grid-x .cb-grid-img img, .cb-grid-x .cb-grid-img .cb-fi-cover { opacity: 0.8; }@media only screen and (min-width: 768px) { .cb-module-block .cb-meta-style-1:hover .cb-article-meta { background: rgba(0, 0, 0, 0.6); } .cb-module-block .cb-meta-style-2:hover img, .cb-module-block .cb-meta-style-4:hover img, .cb-grid-x .cb-grid-feature:hover img, .cb-grid-x .cb-grid-feature:hover .cb-fi-cover, .cb-slider li:hover img { opacity: 0.4; } }#cb-footer { color:#ffffff; }body { font-size: 18px; }@media only screen and (min-width: 1020px){ body { font-size: 18px; }}.cb-menu-light #cb-nav-bar .cb-main-nav, .cb-stuck.cb-menu-light #cb-nav-bar .cb-nav-bar-wrap { border-bottom-color: #99cc00; }</style><style type="text/css">body, #respond, .cb-font-body { font-family: 'Droid Sans', sans-serif; } h1, h2, h3, h4, h5, h6, .cb-font-header, #bbp-user-navigation, .cb-byline{ font-family:'Roboto Condensed', Arial, Helvetica, sans-serif; }</style><meta name="onesignal" content="wordpress-plugin" /> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.sohh.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b979230b-9b58-496d-b012-c935add90cdb';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.sohh.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.235723f6-f2ef-49f2-bb5e-e966332d4e54";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['siteName'] = 'SOHH';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['colors'] = {};
oneSignal_options['notifyButton']['colors']['circle.background'] = '#99cc00';
oneSignal_options['notifyButton']['colors']['circle.foreground'] = '#FFFFFF';
oneSignal_options['notifyButton']['colors']['dialog.button.background.active'] = '#0099CC';
oneSignal_options['notifyButton']['offset'] = {};
oneSignal_options['notifyButton']['offset']['bottom'] = '80px';
oneSignal_options['notifyButton']['offset']['left'] = '20px';
oneSignal_options['notifyButton']['offset']['right'] = '20px';
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <style>.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-50885:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-50885:focus { background:# !important ; } .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-50885 .cb-big-menu { border-top-color: #; }</style><script data-ad-client="ca-pub-3071501482720963" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://www.sohh.com/wp-content/uploads/2020/07/cropped-512x512-1-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.sohh.com/wp-content/uploads/2020/07/cropped-512x512-1-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.sohh.com/wp-content/uploads/2020/07/cropped-512x512-1-1-180x180.png" /><meta name="msapplication-TileImage" content="https://www.sohh.com/wp-content/uploads/2020/07/cropped-512x512-1-1-270x270.png" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>  <meta name="robots" content="max-image-preview:large">  <script data-cfasync="false" type="text/javascript">function ready(fn) {
				if (document.readyState != 'loading') {
					fn();
				} else if (document.addEventListener) {
					document.addEventListener('DOMContentLoaded', fn);
				} else {
					document.attachEvent('onreadystatechange', function() {
						if (document.readyState != 'loading')
							fn();
					});
				}
			}
			ready(function() {
			// REPLACE THIS WITH YOUR OWN SITE. ESCAPE ANY BACKSLASHES.
			var website = 'www\\.sohh\\.com';

			var internalLinkRegex = new RegExp('^((((http:\\/\\/|https:\\/\\/)(www\\.)?)?'
																				 + website
																				 + ')|(localhost:\\d{4})|(\\/.*))(\\/.*)?$', '');

			var anchorEls = document.querySelectorAll('a');
			var anchorElsLength = anchorEls.length;

			for (i = 0; i < anchorElsLength; i++) {
				var anchorEl = anchorEls[i];
					var href = anchorEl.getAttribute('href');
					if (!internalLinkRegex.test(href)) {
						anchorEl.setAttribute('target', '_blank');
					}
				}
			});</script>   <script data-cfasync="false" type="text/javascript">var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  // Tag IDs set here, must match Tags served in the Body for proper setup
  freestar.config.enabled_slots = [
	"sohh_728x90_300x250_ATF",
	"sohh_728x90_300x250_incontent_2",
    "sohh_300x250_300x600_160x600_Sidebar_1",
    "sohh_300x250_300x600_160x600_Sidebar_2",
    "sohh_300x250_300x600_160x600_Sidebar_3"
  ];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/sohh-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);</script>  <script async src="https://powerad.ai/script.js"></script> <link rel="preconnect" href="https://config.playwire.com" crossorigin /><link rel="preconnect" href="https://cdn.intergi.com" crossorigin /><link rel="preconnect" href="https://cdn.intergient.com" crossorigin /><link rel="preconnect" href="https://securepubads.g.doubleclick.net" crossorigin /><link rel="preconnect" href="https://cdn.playwire.com" crossorigin /><link rel="preconnect" href="https://cdn.video.playwire.com" crossorigin /><link rel="preconnect" href="https://cdn.video.playwire.com" crossorigin /><link rel="preconnect" href="https://z.moatads.com" crossorigin /> <script type="text/javascript">var tyche = { mode: 'tyche', config: '//config.playwire.com/13141/v2/websites/10439/banner.json' };</script> <script type="text/javascript">function docReady(fn) {
    if (document.readyState === "complete" || document.readyState === "interactive") {
        setTimeout(fn, 1);
    } else {
        document.addEventListener("DOMContentLoaded", fn);
    }
} 

docReady(function() {
    script1 = document.createElement('script');
    script1.id = 'tyche';
    script1.src = "//cdn.intergi.com/hera/tyche.js";
    document.head.appendChild(script1);
    console.log("Playwire Activated");
});</script> </head><body class="post-template-default single single-post postid-286774 single-format-standard  cb-sticky-mm  cb-tm-light cb-body-light cb-menu-light cb-mm-light cb-footer-dark   cb-m-sticky cb-sw-tm-fw cb-sw-header-box cb-sw-menu-box cb-sw-footer-fw cb-menu-al-left  cb-fis-b-standard  cb-fis-tl-st-below">  <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1708226882617995');
  fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1708226882617995&ev=PageView&noscript=1"
/></noscript> <div id="cb-outer-container"><div id="cb-top-menu" class="clearfix cb-font-header  cb-tm-only-mob"><div class="wrap clearfix cb-site-padding cb-top-menu-wrap"><div class="cb-left-side cb-mob"><a href="#" id="cb-mob-open" class="cb-link"><i class="fa fa-bars"></i></a><div id="mob-logo" class="cb-top-logo"> <a href="https://www.sohh.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt=" logo" data-at2x="https://www.sohh.com/wp-content/uploads/2017/08/Untitled-2.png" data-lazy-src="https://www.sohh.com/wp-content/uploads/2017/08/Untitled-2.png"><noscript><img src="https://www.sohh.com/wp-content/uploads/2017/08/Untitled-2.png" alt=" logo" data-at2x="https://www.sohh.com/wp-content/uploads/2017/08/Untitled-2.png"></noscript> </a></div></div><ul class="cb-top-nav cb-only-mob-menu cb-right-side"><li class="cb-icon-search cb-menu-icons-extra"><a href="#" title="Search" id="cb-s-trigger-mob"><i class="fa fa-search"></i></a></li></ul></div></div><div id="cb-mob-menu" class="cb-mob-menu"><div class="cb-mob-close-wrap"> <a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a><div class="cb-mob-social"> <a href="https://www.facebook.com/sohhdotcom" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a></div></div><div class="cb-mob-menu-wrap"><ul id="cb-mob-ul" class="cb-mobile-nav cb-top-nav cb-mob-ul-show"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50887"><a href="/">HOME</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-50885"><a title="News" href="https://www.sohh.com/category/news/">NEWS</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-255984"><a title="In Case You Missed It" href="https://www.sohh.com/tag/icymi/">ICYMI</a></li><li class="featured-menu-tab menu-item menu-item-type-post_type menu-item-object-page menu-item-282349"><a href="https://www.sohh.com/sow/">SOW.</a></li></ul></div></div><div id="cb-container" class="clearfix"> <header id="cb-header" class="cb-header  wrap"><div id="cb-logo-box" class="cb-logo-center wrap"><div id="logo"> <a href="https://www.sohh.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="SOHH.com 25th Anniversary Logo" data-lazy-src="https://www.sohh.com/wp-content/uploads/2017/08/140x140.png"><noscript><img src="https://www.sohh.com/wp-content/uploads/2017/08/140x140.png" alt="SOHH.com 25th Anniversary Logo" ></noscript> </a></div></div></header><div id="cb-menu-search" class="cb-s-modal cb-modal"><div class="cb-close-m cb-ta-right"><i class="fa cb-times"></i></div><div class="cb-s-modal-inner cb-pre-load cb-light-loader cb-modal-inner cb-font-header cb-mega-three cb-mega-posts clearfix"><form method="get" class="cb-search" action="https://www.sohh.com/"><input type="text" class="cb-search-field cb-font-header" placeholder="Search.." value="" name="s" title="" autocomplete="off"> <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button></form><div id="cb-s-results"></div></div></div> <nav id="cb-nav-bar" class="clearfix  wrap"><div class="cb-nav-bar-wrap cb-site-padding clearfix cb-font-header  wrap"><ul class="cb-main-nav wrap clearfix"><li id="menu-item-50887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50887"><a href="/">HOME</a></li><li id="menu-item-50885" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-50885"><a title="News" href="https://www.sohh.com/category/news/">NEWS</a></li><li id="menu-item-255984" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-255984"><a title="In Case You Missed It" href="https://www.sohh.com/tag/icymi/">ICYMI</a></li><li id="menu-item-282349" class="featured-menu-tab menu-item menu-item-type-post_type menu-item-object-page menu-item-282349"><a href="https://www.sohh.com/sow/">SOW.</a></li><li class="cb-icon-search cb-menu-icons-extra"><a href="#" title="Search" id="cb-s-trigger-gen"><i class="fa fa-search"></i> <span class="cb-search-title">Search</span></a></li><li class="cb-menu-icons-extra cb-social-icons-extra"><a href="http://www.twitter.com/sohhdotcom" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a></li><li class="cb-menu-icons-extra cb-social-icons-extra"><a href="http://www.facebook.com/sohhdotcom" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a></li><li class="cb-menu-icons-extra cb-social-icons-extra"><a href="http://www.instagram.com/sohhdotcom" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i></a></li></ul></div> </nav><div id="cb-content" class="wrap clearfix"><div class="cb-entire-post cb-first-alp clearfix"><div class="cb-post-wrap cb-wrap-pad wrap clearfix cb-sidebar-right"><meta itemprop="datePublished" content="2020-08-24T07:10:34-04:00"><meta itemprop="dateModified" content="2020-08-24T11:49:05-04:00"><meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/"> <span class="cb-hide" itemscope itemprop="publisher" itemtype="https://schema.org/Organization"><meta itemprop="name" content=""><meta itemprop="url" content="https://www.sohh.com/wp-content/uploads/2017/08/140x140.png"> <span class="cb-hide" itemscope itemprop="logo" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.sohh.com/wp-content/uploads/2017/08/140x140.png"> </span> </span> <span class="cb-hide" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Angie Dare"></span><meta itemprop="headline" content="Gucci Mane&#8217;s Wife Keyshia Ka&#8217;oir Shows Off Growing Baby Bump In High Heels: &#8220;Mrs Davis&#8221;"><span class="cb-hide" itemscope itemtype="http://schema.org/ImageObject" itemprop="image"><meta itemprop="url" content="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19.jpg"><meta itemprop="width" content="1600"><meta itemprop="height" content="1200"> </span><div class="cb-main clearfix"> <article id="post-286774" class="clearfix post-286774 post type-post status-publish format-standard has-post-thumbnail category-news tag-gucci-mane tag-keyshia-kaoir"><div id="cb-featured-image" class="cb-fis cb-fis-block-standard"><div class="cb-mask"><img width="759" height="500" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20759%20500'%3E%3C/svg%3E" class="attachment-cb-759-500 size-cb-759-500 wp-post-image" alt="Gucci Mane wants to sign female artist" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-759x500.jpg 759w, https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-100x65.jpg 100w, https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-260x170.jpg 260w" data-lazy-sizes="(max-width: 759px) 100vw, 759px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-759x500.jpg" /><noscript><img width="759" height="500" src="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-759x500.jpg" class="attachment-cb-759-500 size-cb-759-500 wp-post-image" alt="Gucci Mane wants to sign female artist" srcset="https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-759x500.jpg 759w, https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-100x65.jpg 100w, https://www.sohh.com/wp-content/uploads/2019/10/Gucci-Mane-Keyshia-Kaoir-10-29-19-260x170.jpg 260w" sizes="(max-width: 759px) 100vw, 759px" /></noscript><span class="cb-credit-line">@sohh @sohhdotcom</span></div><div class="cb-entry-header hentry cb-meta clearfix"><h1 class="entry-title cb-entry-title entry-title cb-title">Gucci Mane&#8217;s Wife Keyshia Ka&#8217;oir Shows Off Growing Baby Bump In High Heels: &#8220;Mrs Davis&#8221;</h1><div class="cb-byline"><span class="cb-author vcard author"><span class="fn"><a href="https://www.sohh.com/author/sohh-on-the-spot/"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2020%2020'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/babed44b6e640950f44473bb78b03103?s=40&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' data-lazy-src="https://secure.gravatar.com/avatar/babed44b6e640950f44473bb78b03103?s=20&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/babed44b6e640950f44473bb78b03103?s=20&#038;r=g' srcset='https://secure.gravatar.com/avatar/babed44b6e640950f44473bb78b03103?s=40&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' /></noscript>Angie Dare</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" updated" datetime="2020-08-24">August 24, 2020 7:10 am</time></span></div><div class="cb-post-meta"><span class="cb-category cb-element"><a href="https://www.sohh.com/category/news/" title="View all posts in NEWS">NEWS</a></span></div></div></div> <section class="cb-entry-content clearfix" itemprop="articleBody"><span class="cb-itemprop" itemprop="reviewBody"><div id="vuukle-powerbar" class="vuukle-powerbar-vertical powerbarBoxDiv" style="position:fixed;                                                             z-index: 10001;                                                            width: 60px;                                                            max-width: 60px;                                                           left: 10px;                                                             top: 160px; " data-styles="position:fixed;                                                             z-index: 10001;                                                            width: 60px;                                                            max-width: 60px;                                                           left: 10px;                                                             top: 160px;"></div><p>Vixen <strong>Keyshia Ka&#8217;oir</strong> is making sure everyone is keeping tabs on her baby bump. The hip-hop model went online this past weekend to share new looks at her growing tummy.</p><h2>Keyshia Ka&#8217;oir&#8217;s Growing Tummy</h2><p>Ka&#8217;oir went to Instagram with some new pics of herself. The shots feature her rocking a pair of high heels and slaying in new outfits.</p><blockquote class="wp-block-quote"><p>&#8220;Mrs Davis ❤️💛🧡💚&#8221; -Keyshia Ka&#8217;oir&#8217;s <a href="https://www.instagram.com/p/CEPjovMpPoW/?utm_source=ig_embed">Instagram</a></p></blockquote><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CEPjovMpPoW/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CEPjovMpPoW/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CEPjovMpPoW/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Mrs Davis ❤️💛🧡💚</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/keyshiakaoir/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Keyshia Ka&#39;oir Davis</a> (@keyshiakaoir) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-08-23T19:11:03+00:00">Aug 23, 2020 at 12:11pm PDT</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div></figure><blockquote class="wp-block-quote"><p>&#8220;Never mind us, we just taking pics!&#8221;</p></blockquote><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CEHXjNjJ8lt/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CEHXjNjJ8lt/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CEHXjNjJ8lt/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Never mind us, we just taking pics!</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/keyshiakaoir/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Keyshia Ka&#39;oir Davis</a> (@keyshiakaoir) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-08-20T14:51:31+00:00">Aug 20, 2020 at 7:51am PDT</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div><figcaption><em>Keyshia Ka&#8217;oir&#8217;s growing tummy keeps getting bigger.</em></figcaption></figure><div class="sohhads-83126a9cce1f011f7204954c8b23a294" id="sohhads-83126a9cce1f011f7204954c8b23a294"></div><h3>High-Key Details</h3><p>In mid-August 2020, Ka&#8217;oir&#8217;s husband <strong>Gucci Mane</strong> <a href="https://www.sohh.com/gucci-mane-shares-must-see-sonogram-of-his-and-keyshia-kaoirs-mini-me-my-baby-otw/">went to Instagram</a> to share a must-see sonogram pic. Mane didn&#8217;t reveal the baby&#8217;s sex but admitted his offspring can&#8217;t enter the world soon enough.</p><blockquote class="wp-block-quote"><p>&#8220;My baby otw 🥶🏹&#8221; -Gucci Mane&#8217;s <a href="https://www.instagram.com/p/CEHPJbCDqnV/?utm_source=ig_embed">Instagram</a></p><p>&#8220;Awwwww my baby 🍼🥰💎👶🏽 We love u❤️&#8221; -Keyshia Ka&#8217;oir</p></blockquote><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CEHPJbCDqnV/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CEHPJbCDqnV/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CEHPJbCDqnV/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">My baby otw 🥶🏹</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/laflare1017/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Gucci Mane</a> (@laflare1017) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-08-20T13:38:05+00:00">Aug 20, 2020 at 6:38am PDT</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div><figcaption><em>Gucci Mane&#8217;s sonogram pic.</em></figcaption></figure><h4>Wait, There&#8217;s More</h4><p>Recently, Keyshia <a href="https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-masterfully-pulls-off-wearing-face-diamonds-in-new-modeling-pics-dont-play-w-me/">went to Instagram</a> to serve up a slideshow of new shots. The pics provided an up-close look at Ka&#8217;oir rocking diamonds on her face.</p><blockquote class="wp-block-quote"><p>&#8220;Dont play with me❣️ Eyes- @kaoir Red KPalette Lips- @kaoir GlossyBabe LipPop Wig- @kaoirhair Install &#8211; @harold_xxv MUA- @mlatricemua&#8221; -Keyshia Ka&#8217;oir&#8217;s <a href="https://www.instagram.com/p/CECG7oWJk0t/">Instagram</a></p><p>&#8220;Pretty Lady ❤️&#8221; -Gucci Mane</p><p>&#8220;😍😍😍😍😍😍&#8221; -Trina</p></blockquote><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CECG7oWJk0t/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CECG7oWJk0t/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CECG7oWJk0t/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Dont play with me❣️ Eyes- @kaoir Red KPalette Lips- @kaoir GlossyBabe LipPop Wig- @kaoirhair Install &#8211; @harold_xxv MUA- @mlatricemua</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/keyshiakaoir/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Keyshia Ka&#39;oir Davis</a> (@keyshiakaoir) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-08-18T13:50:06+00:00">Aug 18, 2020 at 6:50am PDT</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div><figcaption><em>Keyshia Ka&#8217;oir&#8217;s face diamonds have her shining bright.</em></figcaption></figure><h4>Before You Go</h4><p>A few days ago, Ka&#8217;oir has <a href="https://www.sohh.com/keyshia-kaoir-gets-draped-in-all-gucci-everything-to-show-off-her-growing-pregnancy-hey-baby/">hit up Instagram</a> to show off pics of herself draped in Gucci attire and showing off her tummy. The shot even sparked a positive reaction from her rap star husband Gucci Mane.</p><blockquote class="wp-block-quote"><p>&#8220;❤️✨&#8221; -Keyshia Ka&#8217;oir&#8217;s <a href="https://twitter.com/sohhdotcom/status/1295510736760905731?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1295510736760905731%7Ctwgr%5E&amp;ref_url=https%3A%2F%2Fwww.sohh.com%2Fwp-admin%2Fpost-new.php">Instagram</a></p><p>&#8220;❤️❤️❤️❤️❤️❤️❤️&#8221; -Trina</p></blockquote><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Love how not even a baby bump is going to slow down <a href="https://twitter.com/KeyshiaKaoir?ref_src=twsrc%5Etfw">@KeyshiaKaoir</a> modeling goals. <a href="https://twitter.com/hashtag/SOHH?src=hash&amp;ref_src=twsrc%5Etfw">#SOHH</a> <a href="https://twitter.com/hashtag/SOHHNews?src=hash&amp;ref_src=twsrc%5Etfw">#SOHHNews</a> <a href="https://t.co/HizcYnrERc">pic.twitter.com/HizcYnrERc</a></p>&mdash; SOHH.com (@sohhdotcom) <a href="https://twitter.com/sohhdotcom/status/1295510736760905731?ref_src=twsrc%5Etfw">August 18, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div><figcaption><em>Keyshia Ka&#8217;oir&#8217;s pregnancy modeling is a beautiful sight.</em></figcaption></figure><blockquote class="wp-block-quote"><p>&#8220;Hey Baby👶🏽❤️&#8221; -Keyshia Ka&#8217;oir&#8217;s <a href="https://twitter.com/sohhdotcom/status/1295082589271752705?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1295082589271752705%7Ctwgr%5E&amp;ref_url=https%3A%2F%2Fwww.sohh.com%2Fwp-admin%2Fpost-new.php">Instagram</a></p><p>&#8220;❤️🏹&#8221; -Gucci Mane</p></blockquote><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">That baby bump flex is haaaaaard! <a href="https://twitter.com/KeyshiaKaoir?ref_src=twsrc%5Etfw">@KeyshiaKaoir</a> out here flexing the mini-me sneak peek! <a href="https://twitter.com/gucci1017?ref_src=twsrc%5Etfw">@gucci1017</a> is winning! <a href="https://twitter.com/hashtag/SOHH?src=hash&amp;ref_src=twsrc%5Etfw">#SOHH</a> <a href="https://twitter.com/hashtag/SOHHNews?src=hash&amp;ref_src=twsrc%5Etfw">#SOHHNews</a> <a href="https://t.co/pwCmBweEL9">pic.twitter.com/pwCmBweEL9</a></p>&mdash; SOHH.com (@sohhdotcom) <a href="https://twitter.com/sohhdotcom/status/1295082589271752705?ref_src=twsrc%5Etfw">August 16, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div><figcaption><em>Keyshia Ka&#8217;oir&#8217;s baby bump draped in all-Gucci everything.</em></figcaption></figure><p></p><div id="vuukle-emote" style='max-width:600px' class="emotesBoxDiv"></div></span><div class="sohhads-3d93b506baabb6b03a53cdc3c9c2042e" id="sohhads-3d93b506baabb6b03a53cdc3c9c2042e"></div><div id="respond"></div><div id="vuukle-comments" class="commentBoxDiv"></div> <script>var VUUKLE_CONFIG = {
		apiKey: "068e1168-62e9-4335-a1cf-088d27318d4b",
		articleId: "286774",
		tags: "Gucci Mane, Keyshia Kaoir",
		author: "Angie Dare",
                        
		// Lang

				wordpressSync: true,
		eventHandler: function (e) {
				console.log(e);
				if (e.eventType == 'wpSync') {
					jQuery.ajax({
						type: 'POST',
						data: {
							"action": "save_comment_to_db",
                            "comment_ID":e.comment_ID,
							"comment_post_ID": e.comment_post_ID,
							"comment_author": e.comment_author,
							"comment_author_email": e.email,
							"comment_author_url": e.comment_author_url,
							"comment_content": e.comment_content,
							"comment_type": e.comment_type,
							"comment_parent_ID": e.comment_parent,
							"user_id": e.user_id,
							"comment_author_IP": e.comment_author_IP,
							"comment_agent": e.comment_agent,
							"comment_approved": e.comment_approved,
							"comment_date": e.comment_date,
							"comment_date_gmt": e.comment_date_gmt,
							"comment_karma": e.comment_karma,
							"_wpnonce": "99c0796d1b" // WPCS: XSS ok
						},
						url: "/wp-admin/admin-ajax.php",
						beforeSend: function () {

						},
						success: function (data) {
                                                  
						}
					});
				}
		},
				// Articles - recommendations in emotes and comments widget
		recommendationsWideImages: false,
				recommendationsProtocol: "https://www.",
				globalRecommendations: true,
		// Colors
		darkMode: false,
		// By Widget
                theme: {color: "99cc00"},
		comments: {
		    auth: {
                vuukle: false,
                password: false,
                facebook: true,
                twitter: true,
                google: true,
                disqus: false,
            },
			hideRecommendedArticles: false,
			hideCommentInputBox: false,
			enabled: true,
			commentingClosed: false,
			maxChars: '1000',
			countToLoad: '5',
			toxicityLimit: '80',
			spamLimit: '90',
			sorting: 'latest',
			transliteration:{
				language: 'en',
				enabledByDefault: false,
			},
		        		},
		emotes: {
			enabled: true,
			hideRecommendedArticles: false,
			size: '42', // icons size
			firstImg: '',
			firstName: 'YASSS!',
			secondImg: '',
			secondName: 'REALLY THO?',
			thirdImg: '',
			thirdName: 'WHATEVA',
			fourthImg: '',
			fourthName: 'LMAO',
			fifthImg: '',
			fifthName:'#BIGMAD',
			sixthImg: '',
			sixthName: 'DAMN',
			disable: [],
					},
		powerbar: {
			enabled: true,
			defaultEmote: 1,
                        			items: [
								'facebook',
								'twitter',
								'whatsapp',
								'linkedin',
								'reddit',
								'google',
								'messenger',
								'flipboard',
								'pinterest',
								'email',
							],
                                                 
                        customUrls: {
                             twitter: `http://twitter.com/share?text=Gucci Mane&#8217;s Wife Keyshia Ka&#8217;oir Shows Off Growing Baby Bump In High Heels: &#8220;Mrs Davis&#8221;&url=https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/&via=sohhdotcom`,  
                        },
                                                		},

	};
	(function () {
		var d = document,
		s = d.createElement('script');
		s.async = true;
                s.src = 'https://cdn.vuukle.com/platform.js';
		(d.head || d.body).appendChild(s);
	})();</script> </section> <footer class="cb-article-footer"><p class="cb-tags cb-post-footer-block"> <a href="https://www.sohh.com/tag/gucci-mane/" rel="tag">Gucci Mane</a><a href="https://www.sohh.com/tag/keyshia-kaoir/" rel="tag">Keyshia Ka'oir</a></p><div id="cb-next-previous-posts" class="cb-next-previous cb-post-block-bg cb-post-footer-block cb-font-header clearfix"><div class="cb-previous-post cb-meta cb-next-previous-block"><div class="cb-arrow"><i class="fa fa-angle-left"></i></div><span class="cb-read-previous-title cb-read-title"><a href="https://www.sohh.com/bernice-burgos-tries-to-pull-off-smoking-a-cigar-but-comes-up-with-spit-in-blooper-video/">Previous Article</a></span><a href="https://www.sohh.com/bernice-burgos-tries-to-pull-off-smoking-a-cigar-but-comes-up-with-spit-in-blooper-video/" class="cb-previous-title cb-title">Bernice Burgos Tries To Pull Off Smoking A Cigar But Comes Up With Spit In Blooper Video</a></div><div class="cb-next-post cb-meta cb-next-previous-block"><div class="cb-arrow"><i class="fa fa-angle-right"></i></div><span class="cb-read-next-title cb-read-title"><a href="https://www.sohh.com/dreezy-turns-michael-jordans-chicago-bulls-jersey-into-an-epic-swimsuit-hardly-home-but-always-reppin/">Next Article</a></span><a href="https://www.sohh.com/dreezy-turns-michael-jordans-chicago-bulls-jersey-into-an-epic-swimsuit-hardly-home-but-always-reppin/" class="cb-next-title cb-title">Dreezy Turns Michael Jordan&#8217;s Chicago Bulls Jersey Into An Epic Swimsuit: &#8220;Hardly Home But Always Reppin&#8221;</a></div></div><div id="cb-related-posts-block" class="cb-post-footer-block cb-arrows-tr cb-module-block clearfix"><h3 class="cb-title cb-title-header">Related Posts</h3><div id="cb-related-posts" class="cb-slider-2 cb-slider cb-meta-below"><ul class="slides clearfix"><li class="cb-style-1 clearfix cb-no-1 post-286677 post type-post status-publish format-standard has-post-thumbnail category-news tag-gucci-mane"><div class="cb-mask"><a href="https://www.sohh.com/gucci-mane-shares-must-see-sonogram-of-his-and-keyshia-kaoirs-mini-me-my-baby-otw/"><img width="360" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%20240'%3E%3C/svg%3E" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Gucci Mane Keyshia Ka&#039;oir Selfie Together" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/04/Gucci-Mane-Keyshia-Kaoir-Selfie-Together-360x240.jpg" /><noscript><img width="360" height="240" src="https://www.sohh.com/wp-content/uploads/2020/04/Gucci-Mane-Keyshia-Kaoir-Selfie-Together-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Gucci Mane Keyshia Ka&#039;oir Selfie Together" /></noscript></a></div><div class="cb-meta"><h4 class="cb-post-title"><a href="https://www.sohh.com/gucci-mane-shares-must-see-sonogram-of-his-and-keyshia-kaoirs-mini-me-my-baby-otw/">Gucci Mane Shares Must-See Sonogram Of His and Keyshia Ka&#8217;oir&#8217;s Mini-Me: &#8220;My Baby OTW&#8221;</a></h4><div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.sohh.com/author/biz-jones/">Biz Jones</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-08-20">August 20, 2020 5:06 pm</time></span></div></div></li><li class="cb-style-1 clearfix cb-no-2 post-286588 post type-post status-publish format-standard has-post-thumbnail category-news tag-gucci-mane tag-keyshia-kaoir"><div class="cb-mask"><a href="https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-masterfully-pulls-off-wearing-face-diamonds-in-new-modeling-pics-dont-play-w-me/"><img width="360" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%20240'%3E%3C/svg%3E" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Face Diamonds Selfie 3" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/08/Keyshia-Kaoir-Face-Diamonds-Selfie-3-360x240.png" /><noscript><img width="360" height="240" src="https://www.sohh.com/wp-content/uploads/2020/08/Keyshia-Kaoir-Face-Diamonds-Selfie-3-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Face Diamonds Selfie 3" /></noscript></a></div><div class="cb-meta"><h4 class="cb-post-title"><a href="https://www.sohh.com/gucci-manes-wife-keyshia-kaoir-masterfully-pulls-off-wearing-face-diamonds-in-new-modeling-pics-dont-play-w-me/">Gucci Mane&#8217;s Wife Keyshia Ka&#8217;oir Masterfully Pulls Off Wearing Face Diamonds In New Modeling Pics: &#8220;Don&#8217;t Play W/ Me&#8221;</a></h4><div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.sohh.com/author/sohh-on-the-spot/">Angie Dare</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-08-19">August 19, 2020 7:49 am</time></span></div></div></li><li class="cb-style-1 clearfix cb-no-1 post-286474 post type-post status-publish format-standard has-post-thumbnail category-news tag-keyshia-kaoir"><div class="cb-mask"><a href="https://www.sohh.com/keyshia-kaoir-keeps-flexing-her-baby-bump-rocking-all-white-everything-gucci-gear/"><img width="360" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%20240'%3E%3C/svg%3E" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Wearing Shades In Front Of A Pool" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/04/Keyshia-Kaoir-Wearing-Shades-In-Front-Of-A-Pool-360x240.jpg" /><noscript><img width="360" height="240" src="https://www.sohh.com/wp-content/uploads/2020/04/Keyshia-Kaoir-Wearing-Shades-In-Front-Of-A-Pool-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Wearing Shades In Front Of A Pool" /></noscript></a></div><div class="cb-meta"><h4 class="cb-post-title"><a href="https://www.sohh.com/keyshia-kaoir-keeps-flexing-her-baby-bump-rocking-all-white-everything-gucci-gear/">Keyshia Ka&#8217;oir Keeps Flexing Her Baby Bump Rocking All-White Everything Gucci Gear</a></h4><div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.sohh.com/author/rosario-harper/">Rosario Harper</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-08-17">August 17, 2020 8:15 pm</time></span></div></div></li><li class="cb-style-1 clearfix cb-no-2 post-286385 post type-post status-publish format-standard has-post-thumbnail category-news tag-keyshia-kaoir"><div class="cb-mask"><a href="https://www.sohh.com/keyshia-kaoir-gets-draped-in-all-gucci-everything-to-show-off-her-growing-pregnancy-hey-baby/"><img width="360" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%20240'%3E%3C/svg%3E" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir and Gucci Mane Selfie Pool Pic" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/04/Keyshia-Kaoir-Gucci-Mane-Selfie-Pool-Pic-360x240.jpg" /><noscript><img width="360" height="240" src="https://www.sohh.com/wp-content/uploads/2020/04/Keyshia-Kaoir-Gucci-Mane-Selfie-Pool-Pic-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir and Gucci Mane Selfie Pool Pic" /></noscript></a></div><div class="cb-meta"><h4 class="cb-post-title"><a href="https://www.sohh.com/keyshia-kaoir-gets-draped-in-all-gucci-everything-to-show-off-her-growing-pregnancy-hey-baby/">Keyshia Ka&#8217;oir Gets Draped In All-Gucci Everything To Show Off Her Growing Pregnancy: &#8220;Hey Baby&#8221;</a></h4><div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.sohh.com/author/sohh-on-the-spot/">Angie Dare</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-08-16">August 16, 2020 3:44 pm</time></span></div></div></li><li class="cb-style-1 clearfix cb-no-1 post-286306 post type-post status-publish format-standard has-post-thumbnail category-news tag-gucci-mane tag-keyshia-kaoir"><div class="cb-mask"><a href="https://www.sohh.com/gucci-mane-and-keyshia-kaoir-announce-pregnancy-in-jaw-dropping-new-baby-bump-lingerie-on-his-d-i-did-gymnastics/"><img width="360" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%20240'%3E%3C/svg%3E" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Boat Goals Gucci Mane" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/07/Keyshia-Kaoir-Boat-Goals-Gucci-Mane-360x240.png" /><noscript><img width="360" height="240" src="https://www.sohh.com/wp-content/uploads/2020/07/Keyshia-Kaoir-Boat-Goals-Gucci-Mane-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Boat Goals Gucci Mane" /></noscript></a></div><div class="cb-meta"><h4 class="cb-post-title"><a href="https://www.sohh.com/gucci-mane-and-keyshia-kaoir-announce-pregnancy-in-jaw-dropping-new-baby-bump-lingerie-on-his-d-i-did-gymnastics/">Gucci Mane and Keyshia Ka&#8217;oir Announce Pregnancy In Jaw-Dropping New Baby Bump Lingerie: &#8220;On His D I Did Gymnastics&#8221;</a></h4><div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.sohh.com/author/clanghorne/">Cyrus Langhorne</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-08-15">August 15, 2020 7:00 am</time></span></div></div></li><li class="cb-style-1 clearfix cb-no-2 post-286008 post type-post status-publish format-standard has-post-thumbnail category-news tag-gucci-mane tag-keyshia-kaoir"><div class="cb-mask"><a href="https://www.sohh.com/keyshia-kaoir-shows-off-her-ridiculous-amount-of-iced-out-jewelry-and-gushes-over-gucci-manes-fashion-drip-that-boy-guwop-clean/"><img width="360" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%20240'%3E%3C/svg%3E" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Selfie June Pic 6" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/06/Keyshia-Kaoir-Selfie-June-Pic-6-360x240.png" /><noscript><img width="360" height="240" src="https://www.sohh.com/wp-content/uploads/2020/06/Keyshia-Kaoir-Selfie-June-Pic-6-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="Keyshia Ka&#039;oir Selfie June Pic 6" /></noscript></a></div><div class="cb-meta"><h4 class="cb-post-title"><a href="https://www.sohh.com/keyshia-kaoir-shows-off-her-ridiculous-amount-of-iced-out-jewelry-and-gushes-over-gucci-manes-fashion-drip-that-boy-guwop-clean/">Keyshia Ka&#8217;oir Shows Off Her Ridiculous Amount Of Iced-Out Jewelry and Gushes Over Gucci Mane&#8217;s Fashion Drip: &#8220;That Boy Guwop Clean&#8221;</a></h4><div class="cb-byline"><span class="cb-author"><span class="fn"><a href="https://www.sohh.com/author/sohh-on-the-spot/">Angie Dare</a></span></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class=" " datetime="2020-08-11">August 11, 2020 7:50 pm</time></span></div></div></li></ul></div></div> </footer> </article> </div>  <aside class="cb-sidebar clearfix"><div id="custom_html-8" class="widget_text extendedwopts-show extendedwopts-desktop extendedwopts-tablet extendedwopts-mobile widget cb-sidebar-widget widget_custom_html"><div class="textwidget custom-html-widget"><div align="center" id="sohh_300x250_300x600_160x600_Sidebar_1"> <script data-cfasync="false" type="text/javascript">freestar.queue.push(function () { googletag.display('sohh_300x250_300x600_160x600_Sidebar_1'); });</script> </div></div></div><div id="sticky-posts-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget cb-sidebar-widget widget_ultimate_posts"><h3 class="cb-sidebar-widget-title cb-widget-title">IN CASE YOU MISSED IT</h3><div class="upw-posts hfeed"> <article class="post-286510 post type-post status-publish format-standard has-post-thumbnail category-news tag-icymi tag-jim-jones tag-meek-mill"><header><div class="entry-image"> <a href="https://www.sohh.com/meek-mill-and-jim-jones-bust-out-the-trucks-and-link-up-in-harlem/" rel="bookmark"> <img width="240" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Meek Mill Music Video Moment Pic 5" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-800x600.jpg 800w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-768x576.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-1536x1152.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5.jpg 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-240x180.jpg" /><noscript><img width="240" height="180" src="https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-240x180.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Meek Mill Music Video Moment Pic 5" srcset="https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-800x600.jpg 800w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-768x576.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5-1536x1152.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/05/Meek-Mill-Music-Video-Moment-Pic-5.jpg 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript> </a></div><h4 class="entry-title"> <a href="https://www.sohh.com/meek-mill-and-jim-jones-bust-out-the-trucks-and-link-up-in-harlem/" rel="bookmark"> Meek Mill and Jim Jones Bust Out The Trucks and Link Up In Harlem </a></h4> </header> <footer> </footer></article> <article class="post-286249 post type-post status-publish format-standard has-post-thumbnail category-news tag-game tag-icymi tag-reason tag-tekashi-6ix9ine"><header><div class="entry-image"> <a href="https://www.sohh.com/game-and-reason-expose-tekashi-6ix9ine-after-nipsey-hussle-tribute-you-was-there-for-60-seconds-and-got-escorted-by-police-back/" rel="bookmark"> <img width="240" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Game soaks in more Dubai vibes" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-240x180.png 240w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-480x360.png 480w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-800x600.png 800w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-768x576.png 768w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-1536x1152.png 1536w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-20x15.png 20w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie.png 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-240x180.png" /><noscript><img width="240" height="180" src="https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-240x180.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Game soaks in more Dubai vibes" srcset="https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-240x180.png 240w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-480x360.png 480w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-800x600.png 800w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-768x576.png 768w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-1536x1152.png 1536w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie-20x15.png 20w, https://www.sohh.com/wp-content/uploads/2020/03/Game-Chills-In-Dubai-Selfie.png 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript> </a></div><h4 class="entry-title"> <a href="https://www.sohh.com/game-and-reason-expose-tekashi-6ix9ine-after-nipsey-hussle-tribute-you-was-there-for-60-seconds-and-got-escorted-by-police-back/" rel="bookmark"> Game and Reason Expose Tekashi 6ix9ine After Nipsey Hussle Tribute: &#8220;You Was There For 60 Seconds and Got Escorted By Police Back&#8221; </a></h4> </header> <footer> </footer></article> <article class="post-286240 post type-post status-publish format-standard has-post-thumbnail category-news tag-doja-cat tag-icymi tag-nas"><header><div class="entry-image"> <a href="https://www.sohh.com/nas-disses-doja-cat-on-new-ultra-black-song-and-the-internet-is-100-percent-here-for-it/" rel="bookmark"> <img width="240" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Nas Selfie Pic In The Mirror 3" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-800x600.jpg 800w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-768x576.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-1536x1152.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3.jpg 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-240x180.jpg" /><noscript><img width="240" height="180" src="https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-240x180.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Nas Selfie Pic In The Mirror 3" srcset="https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-800x600.jpg 800w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-768x576.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3-1536x1152.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/04/Nas-Selfie-Pic-In-The-Mirror-3.jpg 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript> </a></div><h4 class="entry-title"> <a href="https://www.sohh.com/nas-disses-doja-cat-on-new-ultra-black-song-and-the-internet-is-100-percent-here-for-it/" rel="bookmark"> Nas Disses Doja Cat On New Ultra Black Song and The Internet Is 100 Percent Here For It </a></h4> </header> <footer> </footer></article></div></div><div id="custom_html-10" class="widget_text extendedwopts-show extendedwopts-desktop extendedwopts-tablet extendedwopts-mobile widget cb-sidebar-widget widget_custom_html"><div class="textwidget custom-html-widget"> <div align="center" id="sohh_300x250_300x600_160x600_Sidebar_2"> <script data-cfasync="false" type="text/javascript">freestar.queue.push(function () { googletag.display('sohh_300x250_300x600_160x600_Sidebar_2'); });</script> </div></div></div><div id="wpp-2" class="widget cb-sidebar-widget popular-posts"><h3 class="cb-sidebar-widget-title cb-widget-title">TRENDING</h3> <ul class="wpp-list"><li><p><img width="240" height="180" loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Tekashi 6ix9ine PSA Lunch Date with Jade" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-800x600.jpg 800w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-768x576.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-1536x1152.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade.jpg 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-240x180.jpg" /><noscript><img width="240" height="180" loading="lazy" src="https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-240x180.jpg" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Tekashi 6ix9ine PSA Lunch Date with Jade" srcset="https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-800x600.jpg 800w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-768x576.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade-1536x1152.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-PSA-Lunch-Date-with-Jade.jpg 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript></p></li><li><div class="wpp-item-data"><a href="https://www.sohh.com/watch-tekashi-6ix9ine-gets-called-a-btch-after-refusing-to-take-picture-with-nyc-bloods/" class="wpp-post-title" target="_self">Watch: Tekashi 6ix9ine Gets Called a &#8220;B*tch&#8221; After Refusing to Take Picture With NYC Bloods</a></div></li><li><p><img width="240" height="180" loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Hennessy Carolina&#039;s New Hairstyle" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-240x180.png 240w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-480x360.png 480w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-800x600.png 800w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-768x576.png 768w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-1536x1152.png 1536w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle.png 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-240x180.png" /><noscript><img width="240" height="180" loading="lazy" src="https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-240x180.png" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Hennessy Carolina&#039;s New Hairstyle" srcset="https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-240x180.png 240w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-480x360.png 480w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-800x600.png 800w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-768x576.png 768w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle-1536x1152.png 1536w, https://www.sohh.com/wp-content/uploads/2020/08/Hennessy-Carolinas-New-Hairstyle.png 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript></p></li><li><div class="wpp-item-data"><a href="https://www.sohh.com/hennessy-carolina-switches-up-her-hair-on-everyone-fleeky/" class="wpp-post-title" target="_self">Hennessy Carolina Switches Up Her Hair On Everyone: &#8220;Fleeky&#8221;</a></div></li><li><p><img width="240" height="180" loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Reginae Carter Selfie Beach Time 3" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-799x600.jpg 799w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-768x577.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-1536x1154.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3.jpg 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-240x180.jpg" /><noscript><img width="240" height="180" loading="lazy" src="https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-240x180.jpg" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Reginae Carter Selfie Beach Time 3" srcset="https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-799x600.jpg 799w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-768x577.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3-1536x1154.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/05/Reginae-Carter-Selfie-Beach-Time-3.jpg 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript></p></li><li><div class="wpp-item-data"><a href="https://www.sohh.com/lil-waynes-daughter-reginae-carter-says-its-a-wrap-im-done-dating-ns-with-kids/" class="wpp-post-title" target="_self">Lil Wayne&#8217;s Daughter Reginae Carter Says It&#8217;s A Wrap: &#8220;I&#8217;m Done Dating N****s With Kids&#8221;</a></div></li><li><p><img width="240" height="180" loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Future Won&#039;t Be Told What To Do" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-799x600.jpg 799w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-768x577.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-1536x1154.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2.jpg 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-240x180.jpg" /><noscript><img width="240" height="180" loading="lazy" src="https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-240x180.jpg" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="Future Won&#039;t Be Told What To Do" srcset="https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-240x180.jpg 240w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-480x360.jpg 480w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-799x600.jpg 799w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-768x577.jpg 768w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2-1536x1154.jpg 1536w, https://www.sohh.com/wp-content/uploads/2020/04/Future-Lori-Harvey-Together-Pic-2.jpg 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript></p></li><li><div class="wpp-item-data"><a href="https://www.sohh.com/future-and-lori-harvey-might-have-officially-called-it-quits-broke-up/" class="wpp-post-title" target="_self">Future and Lori Harvey Might Have Officially Called It Quits + Broke Up</a></div></li><li><p><img width="240" height="180" loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20240%20180'%3E%3C/svg%3E" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-240x180.png 240w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-480x360.png 480w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-800x600.png 800w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-768x576.png 768w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-1536x1152.png 1536w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2.png 1600w" data-lazy-sizes="(max-width: 240px) 100vw, 240px" data-lazy-src="https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-240x180.png" /><noscript><img width="240" height="180" loading="lazy" src="https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-240x180.png" class="wpp-thumbnail wpp_featured attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-240x180.png 240w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-480x360.png 480w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-800x600.png 800w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-768x576.png 768w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2-1536x1152.png 1536w, https://www.sohh.com/wp-content/uploads/2020/04/Summer-Walker-Selfie-Bathroom-Pic-2.png 1600w" sizes="(max-width: 240px) 100vw, 240px" /></noscript></p></li><li><div class="wpp-item-data"><a href="https://www.sohh.com/summer-walker-is-an-entire-vibe-rocking-all-white-skirt-during-outdoor-performance/" class="wpp-post-title" target="_self">Summer Walker Is An Entire Vibe Rocking All-White Skirt During Outdoor Performance</a></div></li></ul></div><div id="custom_html-9" class="widget_text extendedwopts-show extendedwopts-desktop extendedwopts-tablet extendedwopts-mobile widget cb-sidebar-widget widget_custom_html"><div class="textwidget custom-html-widget"><div align="center" id="sohh_300x250_300x600_160x600_Sidebar_3"> <script data-cfasync="false" type="text/javascript">freestar.queue.push(function () { googletag.display('sohh_300x250_300x600_160x600_Sidebar_3'); });</script> </div></div></div></aside></div></div></div> </div> <footer id="cb-footer"><div id="cb-widgets" class="cb-footer-x cb-footer-e wrap clearfix cb-site-padding"><div class="cb-one cb-column clearfix"><div id="cb-social-media-widget-2" class="widget cb-footer-widget clearfix cb-widget-social-media clearfix"><div class="cb-social-media-icons cb-white"><a href="https://www.instagram.com/sohhdotcom" target="_blank" class="cb-instagram cb-icon-1"></a><a href="https://www.facebook.com/sohhdotcom" target="_blank" class="cb-facebook cb-icon-2"></a><a href="https://twitter.com/sohhdotcom" target="_blank" class="cb-twitter cb-icon-3"></a><a href="https://www.youtube.com/sohhdotcom" target="_blank" class="cb-youtube cb-icon-4"></a></div></div></div></div><div class="cb-footer-lower cb-font-header clearfix"><div class="wrap clearfix"><div id="cb-footer-logo"> <a href="https://www.sohh.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt=" logo" data-at2x="https://www.sohh.com/wp-content/uploads/2017/08/170x160.png" data-lazy-src="https://www.sohh.com/wp-content/uploads/2017/08/80x80.png"><noscript><img src="https://www.sohh.com/wp-content/uploads/2017/08/80x80.png" alt=" logo"  data-at2x="https://www.sohh.com/wp-content/uploads/2017/08/170x160.png"></noscript> </a></div><div class="cb-copyright"><h3 style="color: rgba(153, 204, 0, 0.6);">XXV YEARS #FACTS #NOCAP</h3><a href="/advertise-on-sohh/">Advertise</a> / <a href="/bad-ads/">Report Bad Ads</a> /
/ <a href="/privacy-policy/">Privacy Policy</a> / <a href="/digital-millennium-copyright-act/">DMCA</a><br /><br />&copy; 1995 - 2020 4CONTROL Media, Inc.</div><div class="cb-to-top"><a href="#" id="cb-to-top"><i class="fa fa-angle-up cb-circle"></i></a></div></div></div> </footer> </div> <span id="cb-overlay"></span> <input type="hidden" id="_zinenonce" name="_zinenonce" value="e1f21294b7" /><input type="hidden" name="_wp_http_referer" value="/gucci-manes-wife-keyshia-kaoir-shows-off-growing-baby-bump-in-high-heels-mrs-davis/" /> <script type="text/javascript">var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":21,"name":"Angie Dare","avatar":"babed44b6e640950f44473bb78b03103"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '12491']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();</script> <script type='text/javascript'>/*  */
var varWidgetOpts = {"shallNotFixed":".site-footer","margin_top":"0","disable_width":"768","disable_height":"200"};
var cbExt = {"cbLb":"off"};
var cbScripts = {"cbUrl":"https:\/\/www.sohh.com\/wp-admin\/admin-ajax.php","cbPostID":"286774","cbFsClass":"cb-embed-fs","cbSlider":["600",true,"5000",true],"cbALlNonce":"423bf1e444","cbPlURL":"https:\/\/www.sohh.com\/wp-content\/plugins","cbShortName":null};
/*  */</script> <script type='text/javascript' src='https://www.sohh.com/wp-content/uploads/cache/fvm/1597860923/out/footer-a2b11d90a915685c02550c40d8738cec60c5e253.min.js'></script><script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js'></script><script>window.advads_passive_placements = {"embed-before-paragraph-3_1":{"elementid":["sohhads-83126a9cce1f011f7204954c8b23a294"],"ads":{"194811":{"id":194811,"title":"EMBED - VUUKLE [BEFORE P 3]","expiry_date":0,"visitors":[],"content":"<div class=\"sohhads-embed-before-paragraph-3\" style=\"margin-top: 10px; margin-bottom: 10px; \" id=\"sohhads-27123040\"><div id=\"vuukle-emoji-app-goes-here\">\r\n\r\n<\/div><\/div>","once_per_page":1,"debugmode":false,"blog_id":1,"type":"plain","position":""}},"type":"ad","id":194811,"placement_info":{"type":"post_content","name":"EMBED - BEFORE PARAGRAPH 3","item":"ad_194811","options":{"lazy_load":"enabled","placement_position":""},"id":"embed-before-paragraph-3"},"test_id":null,"inject_before":[""]},"after-content_2_3":{"elementid":["sohhads-3d93b506baabb6b03a53cdc3c9c2042e"],"ads":{"269344":{"id":269344,"title":"FREESTAR \u2013 IAB \u2013 INCONTENT_3","expiry_date":0,"visitors":[],"content":"<div class=\"sohhads-after-content_2 freestar-ads\" id=\"sohhads-1786588629\"><!-- Tag ID: sohh_728x90_300x250_incontent_3 -->\r\n<div align=\"center\" id=\"sohh_728x90_300x250_incontent_3\">\r\n<script data-cfasync=\"false\" type=\"text\/javascript\">\r\n    freestar.queue.push(function () { googletag.display('sohh_728x90_300x250_incontent_3'); });\r\n<\/script>\r\n<\/div><\/div>","once_per_page":1,"debugmode":false,"blog_id":1,"type":"plain","position":""}},"type":"ad","id":269344,"placement_info":{"type":"post_bottom","name":"AFTER CONTENT 2","item":"ad_269344","options":{"lazy_load":"enabled","placement_position":""},"key":"after-content_2","id":"after-content_2"},"test_id":null,"inject_before":[""]}};

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');} });</script><script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://www.sohh.com/wp-content/plugins/rocket-lazy-load/assets/js/16.1/lazyload.js"></script> </body></html> 